BGP Attribute Community

No Export : Network tidak di advertise ke External BGP, hanya di IBGP saja
No Advertise : Network tidak di advertise ke Internal BGP dan External BGP
Local AS : attribute ini hanya di BGP Confederation, tidak di advertise ke
 sub as yang lain, hanya di advertise di sub as yang sama





BGP Attribute Community No Export

Konfigurasi IP Address di R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!       
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!       
interface Ethernet0/1
 ip address 12.12.12.1 255.255.255.0
!     


Konfigurasi IP Address di R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!       
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
!       
interface Ethernet0/0
 ip address 42.42.42.1 255.255.255.0
!       
interface Ethernet0/1
 ip address 12.12.12.2 255.255.255.0
!       
interface Ethernet0/2
 ip address 23.23.23.1 255.255.255.0
!       


Konfigurasi IP Address di R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!       
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!       
interface Ethernet0/2
 ip address 23.23.23.2 255.255.255.0
!   

Konfigurasi IP Address di R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!       
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
!       
interface Ethernet0/0
 ip address 42.42.42.2 255.255.255.0
!       



Konfigurasi EIGRP di R1

router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 12.12.12.0 0.0.0.255



Konfigurasi EIGRP di R2

router eigrp 10
 network 2.2.2.2 0.0.0.0
 network 12.12.12.0 0.0.0.255
 network 23.23.23.0 0.0.0.255
 network 42.42.42.0 0.0.0.255
!     


Konfigurasi EIGRP di R3

router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 23.23.23.0 0.0.0.255



Konfigurasi EIGRP di R4

router eigrp 10
 network 4.4.4.4 0.0.0.0
 network 42.42.42.0 0.0.0.255


Di Router 1

Konfigurasi Access-list dan route map NO-EXPORT

access-list 1 NO-EXPORT permit host 11.11.11.11
route-map NO-EXPORT
match ip address 1


Konfigurasi BGP AS 100 di R1 lengkap dengan Attribute No Export

router bgp 100
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 send-community
 neighbor 2.2.2.2 route-map NO-EXPORT out
!

Konfigurasi BGP di R2

router bgp 100
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 route-reflector-client
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 next-hop-self
 neighbor 42.42.42.2 remote-as 200
 neighbor 42.42.42.2 next-hop-self
!     

Di sini terlihat R1 dan R3 adalah Route Reflector Client, dan R2 adalah route
reflector server

Konfigurasi BGP di R3

router bgp 100
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 42.42.42.2 remote-as 200
 neighbor 42.42.42.2 next-hop-self
!   

Konfigurasi BGP di R4

router bgp 200
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 42.42.42.1 remote-as 100
 neighbor 42.42.42.1 next-hop-self
!   


selanjutnya di cek di R2 ataupun R4

R2#sh ip bgp
BGP table version is 16, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 11.11.11.11/32   1.1.1.1                  0    100      0 i
 *>  22.22.22.22/32   0.0.0.0                  0         32768 i
 *>i 33.33.33.33/32   3.3.3.3                  0    100      0 i
 *>  44.44.44.44/32   42.42.42.2               0             0 200 i


 Pada BGP Table ip loopback 11.11.11.11 masih terlihat, kemudian cek status
bgp 11.11.11.11 di R2

R2#sh ip bgp 11.11.11.11
BGP routing table entry for 11.11.11.11/32, version 16
Paths: (1 available, best #1, table default, not advertised to EBGP peer)
  Advertised to update-groups:
     3       
  Refresh Epoch 1
  Local, (Received from a RR-client)
    1.1.1.1 (metric 409600) from 1.1.1.1 (11.11.11.11)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Community: no-export
      rx pathid: 0, tx pathid: 0x0


Yap ip loopback 11.11.11.11 status community : no-export untuk membuktikan
bahwa 11.11.11.11 dengan status community no-export artinya tidak di advertise
ke AS lain (EBGP) coba cek di R4

R4#sh ip bgp
BGP table version is 8, local router ID is 44.44.44.44
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  22.22.22.22/32   42.42.42.1               0             0 100 i
 *>  33.33.33.33/32   42.42.42.1                             0 100 i
 *>  44.44.44.44/32   0.0.0.0                  0         32768 i
R4#


Mantab pada table BGP di R4 tidak terlihat adanya ip loopback R1 yaitu
11.11.11.11/32, artinya konfigurasi tersebut berhasil


BGP Attribute Community No Advertise

IP Address beserta routing EIGRP dan BGP masih tetap sama dengan lab sebelumnya
disini kita akan menambahkan atau meneruskan saja yaitu IP Loopback:
R3 akan berstatus No Advertise

Di Router 3

Konfigurasi Access-list dan route map NO-EXPORT

access-list 1 NO-ADVERTISE permit host 33.33.33.33
route-map NO-AVERTISE
match ip address 1

Konfigurasi BGP di R3
 
router bgp 100
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 send-community
 neighbor 2.2.2.2 route-map NO-ADVERTISE out
 neighbor 42.42.42.2 remote-as 200
 neighbor 42.42.42.2 next-hop-self
!     



kemudian clear ip bgpnya

sh ip route bgp *


kemudian lihat di R2

R2#sh ip bgp
BGP table version is 18, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 11.11.11.11/32   1.1.1.1                  0    100      0 i
 *>  22.22.22.22/32   0.0.0.0                  0         32768 i
 *>  44.44.44.44/32   42.42.42.2               0             0 200 i
R2#


Pada table bgp di R3 terlihat bahwa IP Loopback R3 tidak terbaca di R2,
kemudian cek status IP Loopback R3

R2#sh ip bgp 33.33.33.33
BGP routing table entry for 33.33.33.33/32, version 19
Paths: (1 available, best #1, table default, not advertised to any peer)
  Not advertised to any peer
  Refresh Epoch 1
  Local, (Received from a RR-client)
    3.3.3.3 (metric 409600) from 3.3.3.3 (33.33.33.33)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Community: no-advertise
      rx pathid: 0, tx pathid: 0x0
R2#


Terlihat bahwa ip loopback 33.33.33.33 berstatus Community no-advertise

kemudian cek di R4

R4#sh ip bgp
BGP table version is 9, local router ID is 44.44.44.44
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  22.22.22.22/32   42.42.42.1               0             0 100 i
 *>  44.44.44.44/32   0.0.0.0                  0         32768 i
R4#


Mantab mas broo terlihat di BGP Table R4 tersebut ip loopback R3 tidak terlihat
hal ini membuktikan bahwa konfigurasi BGP Community No-Advertise berhasil.

BGP Attribute Community  No Route :
IBGP terlihat, tapi di EBGP tidak terlihat
BGP Attribute Community No Advertise :
IBGP tidak terlihat, di EBGP juga tidak terlihat



BGP Attribute Community  Local AS

Untuk IP Addres dan EIGRPnya tetap sama dengan yang lab sebelumnya,
hanya saja BGP di R1 R2 dan R3 di hapus, di R4 tidak di hapus



Konfigurasi Access-list dan route map LOCAl-AS

access-list 1 LOCAL-AS permit host 11.11.11.11
route-map LOCAL-AS
match ip address 1

bentuk bgp confederation di R1 R2 dan R3

di Router 1

router bgp 1001
 bgp log-neighbor-changes
 bgp confederation identifier 100
 bgp confederation peers 1002 1003 
 network 11.11.11.11 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 1002
 neighbor 12.12.12.2 next-hop-self
 neighbor 12.12.12.2 route-map LOCAL-AS out
!         


di Router 2

router bgp 1002
 bgp log-neighbor-changes
 bgp confederation identifier 100
 bgp confederation peers 1001 1003 
 network 22.22.22.22 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 1001
 neighbor 12.12.12.1 next-hop-self
 neighbor 23.23.23.2 remote-as 1003
 neighbor 23.23.23.2 next-hop-self
 neighbor 42.42.42.2 remote-as 200
 neighbor 42.42.42.2 next-hop-self
!         


di Router 3

router bgp 1003
 bgp log-neighbor-changes
 bgp confederation identifier 100
 bgp confederation peers 1001 1002 
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 1002
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 neighbor 23.23.23.1 remote-as 1002
 neighbor 23.23.23.1 next-hop-self
!         


di Router 4

router bgp 200
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 42.42.42.1 remote-as 100
 neighbor 42.42.42.1 next-hop-self
!     


selanjutnya cek di routing table BGP R2

R2(config-router)#do sh ip bgp
BGP table version is 8, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  22.22.22.22/32   0.0.0.0                  0         32768 i
 *>  33.33.33.33/32   23.23.23.2               0    100      0 (1003) i
 *>  44.44.44.44/32   42.42.42.2    


Mantabb mas broo, IP Loopback R1 yaitu 11.11.11.11 tidak muncul di Routing
tabel BGP R2, hal ini menandakan konfigurasi BGP Attribute Community Local AS
telah berhasil.

Sampai sini Lab BGP Attribute Community No Export, No Advertise dan Local AS
telah berhasil di konfigurasi. Selesei

Salam Ngoprek




Leave a Reply