LAB 6. MPLS & L3VPN MENGGUNAKAN OSPF ROUTING

- Mempelajari MPLS & L3VPN antara PE dan CE menggunakan OSPF Routing
- Penambahan CE R6 menggunakan routing RIP

Konfigurasikan IP Address dan mengaktifkan MPLS serta LDP di Router 2 - PE

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!       
interface Ethernet0/0
 ip address 23.23.23.2 255.255.255.0
 mpls ip 


mpls label protocol ldp
mpls ldp router-id Loopback0 force

Konfigurasikan routing OSPF di Router 2 - PE
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!

Konfigurasikan Virtual Routing Forwarding di Router 2 - PE untuk Router CAR2
 ip vrf car2
 rd 1:10 
 route-target export 1:105
 route-target import 1:105

Konfigurasikan MP-BGP dan Aktifkan VPNV4
router bgp 234
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 234
 neighbor 4.4.4.4 update-source Loopback0
 !       
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family
 !       

Konfigurasikan VRF di Interface menuju ke CAR2  serta berikan IP Addressnya

interface Ethernet0/1
 ip vrf forwarding car2
 ip address 12.12.12.2 255.255.255.0
!     

Konfigurasikan routing OSPF yang berjalan pada VRF di Router 2 - PE

router ospf 100 vrf car2
 router-id 0.0.0.1
 domain-id 0.0.0.1
 network 12.12.12.2 0.0.0.0 area 0
!   

Konfigurasikan Redistribute OSPF vrf di MP-BGP

router bgp 234
 address-family ipv4 vrf car2
  redistribute ospf 100
 exit-address-family
!       

Konfigurasikan Redistribute BGP ke OSPF vrf

router ospf 100 vrf car2
redistribute bgp 234 subnets
!




Konfigurasikan IP Address dan mengaktifkan MPLS serta LDP di Router 3-P

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!       
interface Ethernet0/0
 ip address 23.23.23.3 255.255.255.0
 mpls ip 
!       
interface Ethernet0/1
 ip address 34.34.34.3 255.255.255.0
 mpls ip 
!       

mpls label protocol ldp
mpls ldp router-id Loopback0 force

Konfigurasikan routing OSPF di Router 3 -PE

router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
 network 34.34.34.3 0.0.0.0 area 0
!     



Konfigurasikan IP Address dan mengaktifkan MPLS serta LDP di Router 4-PE

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!       
interface Ethernet0/0
 ip address 34.34.34.4 255.255.255.0
 mpls ip 
!       

mpls label protocol ldp
mpls ldp router-id Loopback0 force

Konfigurasikan routing OSPF di R4-PE

router ospf 1
 router-id 4.4.4.4
 network 4.4.4.4 0.0.0.0 area 0
 network 34.34.34.4 0.0.0.0 area 0
!       

Konfigurasikan Virtual Routing Forwarding di R4-PE untuk Router CAR4

ip vrf car4
rd 1:20 
route-target export 1:105
route-target import 1:105
!       

Konfigurasikan Virtual Routing Forwarding di R4-PE untuk Router CBR6

ip vrf cbr6
 rd 1:30 
 route-target export 1:600
 route-target import 1:600

Konfigurasikan MP-BGP dan aktifkan VPNV4 di Router 4-PE

router bgp 234
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 234
 neighbor 2.2.2.2 update-source Loopback0
 !       
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
 exit-address-family
 !       

Konfigurasikan VRF di Interface menuju ke CAR4 dan CBR6  serta berikan
IP Addressnya

interface Ethernet0/1
 ip vrf forwarding car4
 ip address 45.45.45.4 255.255.255.0
!       
interface Ethernet0/2
 ip vrf forwarding cbr6
 ip address 46.46.46.4 255.255.255.0
!       

Konfigurasikan OSPF vrf car4 sekaligus redistribute bgp di Router 4-PE

router ospf 100 vrf car4
 domain-id 0.0.0.1
 redistribute bgp 234 subnets
 network 45.45.45.4 0.0.0.0 area 0
!     

Konfigurasikan RIPv2 vrf cbr6 sekaligus redistribute bgp  di Router 4-PE

router rip
 version 2
 !       
 address-family ipv4 vrf cbr6
  redistribute bgp 234 metric transparent
  network 46.0.0.0
  no auto-summary
  version 2
 exit-address-family
!       

Konfigurasikan Redistribute OSPF ke BGP, dan RIPv2 ke BGP di Router 4 -PE

router bgp 234
address-family ipv4 vrf car4
  redistribute ospf 100
 exit-address-family
 !       
 address-family ipv4 vrf cbr6
  redistribute rip
 exit-address-family
!

============================================================================

Pada Lab ini dalam Router 2-PE dan Router 4-PE terdapat routing OSPF, OSPF 1
dengan backbone area 0 dan tertanam pada R2-PE R3-P dan R4-PE, kemudian OSPF
100 dengan backbone area 0 namun berjalan dibawah VRF CAR2 dan CAR4 pada
Router 2-PE dan Router 4-PE, agar Router OSPF 100 membaca OSPF 1 tidak sebagai
Inter Area, sehingga kedua router membaca status asli masing masing OSPF
untuk menangani permasalhan tersebut maka di konfigurasikanlah Domain-ID di
OSPF 100 vrf car2 di R2-PE serta OSPF vrf car4 di R4-PE


di Router 2-PE

router ospf 100 vrf car2
 router-id 0.0.0.1
 domain-id 0.0.0.1

di Router 4-PE

router ospf 100 vrf car4
 router-id 0.0.0.1
 domain-id 0.0.0.1

Konfigurasi IP Address dan Routing OSPF di CAR2 yang terhbung R2-PE

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!       
interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0
!     

router ospf 100
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!   

Konfigurasikan IP Address dan Routing OSPF di CAR4 yang terhbung R4-PE

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!       
interface Ethernet0/0
 ip address 45.45.45.5 255.255.255.0
!     

router ospf 100
 network 5.5.5.5 0.0.0.0 area 0
 network 45.45.45.5 0.0.0.0 area 0


Konfigurasikan IP Address dan Routing RIPv2 di CBR6 yang terhbung R4-PE

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!       
interface Ethernet0/0
 ip address 46.46.46.6 255.255.255.0
!   

router rip
 version 2
 network 6.0.0.0
 network 46.0.0.0
 no auto-summary
!   

KOnfigurasikan agar router CBR6 dapat berkomunikasi dengan CAR2
yaitu dengan mengimport route-target 1:600 di vrf cbr6 pada R4-PE dan
mengimport route-target 1:105 di vrf car2 pada R2-PE

 
di Router4-PE

ip vrf cbr6
 rd 1:30
 route-target import 1:105

di Router2-PE

ip vrf car2
 rd 1:10
 route-target import 1:600


Verifikasi bgp vpnv4 di R2-PE

R2-PE#sh ip bgp vpnv4 all | b Net
     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:10 (default for vrf car2)
 *>  1.1.1.1/32       12.12.12.1              11         32768 ?
 *>i 5.5.5.5/32       4.4.4.4                 11    100      0 ?
 *>i 6.6.6.6/32       4.4.4.4                  1    100      0 ?
 *>  12.12.12.0/24    0.0.0.0                  0         32768 ?
 *>i 45.45.45.0/24    4.4.4.4                  0    100      0 ?
 *>i 46.46.46.0/24    4.4.4.4                  0    100      0 ?
Route Distinguisher: 1:20
 *>i 5.5.5.5/32       4.4.4.4                 11    100      0 ?
 *>i 45.45.45.0/24    4.4.4.4                  0    100      0 ?
Route Distinguisher: 1:30
 *>i 6.6.6.6/32       4.4.4.4                  1    100      0 ?
 *>i 46.46.46.0/24    4.4.4.4                  0    100      0 ?
R2-PE#


Verifikasi ip bgp vpnv4 di R4-PE

R4-PE#sh ip bgp vpnv4 all | b Net
     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:10
 *>i 1.1.1.1/32       2.2.2.2                 11    100      0 ?
 *>i 12.12.12.0/24    2.2.2.2                  0    100      0 ?
Route Distinguisher: 1:20 (default for vrf car4)
 *>i 1.1.1.1/32       2.2.2.2                 11    100      0 ?
 *>  5.5.5.5/32       45.45.45.5              11         32768 ?
 *>i 12.12.12.0/24    2.2.2.2                  0    100      0 ?
 *>  45.45.45.0/24    0.0.0.0                  0         32768 ?
Route Distinguisher: 1:30 (default for vrf cbr6)
 *>i 1.1.1.1/32       2.2.2.2                 11    100      0 ?
 *>  5.5.5.5/32       45.45.45.5              11         32768 ?
 *>  6.6.6.6/32       46.46.46.6               1         32768 ?
 *>i 12.12.12.0/24    2.2.2.2                  0    100      0 ?
 *>  45.45.45.0/24    0.0.0.0                  0         32768 ?
 *>  46.46.46.0/24    0.0.0.0                  0         32768 ?
R4-PE#

Verifikasi RIP di Router CBR6

CBR6#sh ip route rip | i R
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
R        1.1.1.1 [120/12] via 46.46.46.4, 00:00:07, Ethernet0/0
R        5.5.5.5 [120/12] via 46.46.46.4, 00:00:07, Ethernet0/0
R        12.12.12.0 [120/1] via 46.46.46.4, 00:00:07, Ethernet0/0
R        45.45.45.0 [120/1] via 46.46.46.4, 00:00:07, Ethernet0/0
CBR6#


Verikasi ping cari CAR2 ke CAR4, dan CBR6 ke CAR2

CAR2#ping 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/8/10 ms
CAR2#ping 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/7 ms
CAR2#



CAR4#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/5/7 ms


CBR6#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/6 ms
CBR6#



Alhamdulillah Mas broo, berhasil dan sudah terhbung dengan baik, selesei.


Salam Ngoprek
     

1 komentar:

  1. terima kasih banyak om, sangat membantu kalo mw ngelab kecil-kecilan

    BalasHapus