BGP Multihoming ISP sama Load Balance


konfigurasi ip address di R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!       
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!   

interface Serial2/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!       
interface Serial2/1
 ip address 13.13.13.1 255.255.255.0
 serial restart-delay 0
!       



Konfigurasi IP Address di R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!       
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
!       
interface Ethernet0/0
 ip address 23.23.23.2 255.255.255.0
!     

interface Serial2/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!       
interface Serial2/1
 ip address 24.24.24.2 255.255.255.0
 serial restart-delay 0
!   


Konfigurasi IP Address di R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!       
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!       
interface Ethernet0/0
 ip address 23.23.23.3 255.255.255.0
!     

interface Serial2/1
 ip address 13.13.13.3 255.255.255.0
 serial restart-delay 0
!       
interface Serial2/2
 ip address 34.34.34.3 255.255.255.0
 serial restart-delay 0


Konfigurasi IP Address di R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!       
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
!     

interface Serial2/1
 ip address 24.24.24.4 255.255.255.0
 serial restart-delay 0
!       
interface Serial2/2
 ip address 34.34.34.4 255.255.255.0
 serial restart-delay 0



Konfigurasi EIGRP dan BGP  di R1 serta load balance jalur menuju R2 dan R3


router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 12.12.12.0 0.0.0.255
 network 13.13.13.0 0.0.0.255
!       
router bgp 1
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 23
 neighbor 12.12.12.2 next-hop-self
 neighbor 13.13.13.3 remote-as 23
 neighbor 13.13.13.3 next-hop-self
 maximum-paths 2
!   


Konfigurasi EIGRP dan BGP  di R2

router eigrp 10
 network 2.2.2.2 0.0.0.0
 network 12.12.12.0 0.0.0.255
 network 23.23.23.0 0.0.0.255
 network 24.24.24.0 0.0.0.255
!       
router bgp 23
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 1
 neighbor 12.12.12.1 next-hop-self
 neighbor 23.23.23.3 remote-as 23
 neighbor 23.23.23.3 next-hop-self
 neighbor 24.24.24.4 remote-as 4
 neighbor 24.24.24.4 next-hop-self
!       

Konfigurasi EIGRP dan BGP  di R3

router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 13.13.13.0 0.0.0.255
 network 23.23.23.0 0.0.0.255
 network 34.34.34.0 0.0.0.255
!       
router bgp 23
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 13.13.13.1 remote-as 1
 neighbor 13.13.13.1 next-hop-self
 neighbor 23.23.23.2 remote-as 23
 neighbor 23.23.23.2 next-hop-self
 neighbor 34.34.34.4 remote-as 4
 neighbor 34.34.34.4 next-hop-self
!       


Konfigurasi EIGRP dan BGP di R4

router eigrp 10
 network 4.4.4.4 0.0.0.0
 network 24.24.24.0 0.0.0.255
 network 34.34.34.0 0.0.0.255
!       
router bgp 4
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 23
 neighbor 24.24.24.2 next-hop-self
 neighbor 34.34.34.3 remote-as 23
 neighbor 34.34.34.3 next-hop-self
!     


Sebelum di konfigurasi load balance di R1

R1#sh ip bgp
BGP table version is 5, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  11.11.11.11/32   0.0.0.0                  0         32768 i
 *   22.22.22.22/32   13.13.13.3                             0 23 i
 *>                   12.12.12.2               0             0 23 i
 *   33.33.33.33/32   12.12.12.2                             0 23 i
 *>                   13.13.13.3               0             0 23 i
 *   44.44.44.44/32   13.13.13.3                             0 23 4 i
 *>                   12.12.12.2                             0 23 4 i


untuk menuju ip loopback 44.44.44.44 bisa menggunaka 2 jalur, namun jalur yang
digunakan bgp defaultnya hanya satu jalur saja, oleh karena itu pada table
bgp di atas jalur best yang dipilih yaitu jalur 12.12.12.2,
 meskpun ada 2 jalur yang aktif tetap hanya satu jalur yang dipilih,
agar lebih paham kita test menggunakan ip route ke 44.44.44.44 dari R1


R1#sh ip route 44.44.44.44
Routing entry for 44.44.44.44/32
  Known via "bgp 1", distance 20, metric 0
  Tag 23, type external
  Last update from 12.12.12.2 00:07:55 ago
  Routing Descriptor Blocks:
  * 12.12.12.2, from 12.12.12.2, 00:07:55 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 23
      MPLS label: none


Terlihat hasil diatas bahwa untuk menuju 44.44.44.44 menggunakan satu jalur saja
yaitu 12.12.12.2 atau R2

kemudian kita konfigurasi agar jalur 13.13.13.3 dapat digunakan juga,
konfigurasinya di BGP R1, dengan menambahkan maximum path, karena ada 2 jalur
maka maximum-path 2, untuk konfigurasi bisa lihat konfigurasi EIGRP dan BGP
di R1 tepatnya diatas yah, silahkan baca kembali konfigurasi diatas.


berikut hasil R1 ketika sudah di konfigurasi maximum path

R1(config-router)#do sh ip route 44.44.44.44
Routing entry for 44.44.44.44/32
  Known via "bgp 1", distance 20, metric 0
  Tag 23, type external
  Last update from 13.13.13.3 00:00:23 ago
  Routing Descriptor Blocks:
    13.13.13.3, from 13.13.13.3, 00:00:23 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 23
      MPLS label: none
  * 12.12.12.2, from 12.12.12.2, 00:00:23 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 23
      MPLS label: none



R1(config)#do trace 44.44.44.44
Type escape sequence to abort.
Tracing the route to 44.44.44.44
VRF info: (vrf in name/id, vrf out name/id)
  1 12.12.12.2 10 msec
    13.13.13.3 10 msec
    12.12.12.2 10 msec
  2 34.34.34.4 19 msec
    24.24.24.4 18 msec
    34.34.34.4 18 msec



Mantabb mas bro, alhamdulillah hasil test ip route dan trace ke 44.44.44.44
menggunakan 2 jalur serta otomatis load balance, karena pada iSP yang sama
dan AS yang sama pula serta kecepatan Bandwidth yang sama pula.


sampai sini selesei

salam ngoprek




Leave a Reply