EIGRP - Filtering ACL
Non Aktifkan dulu Network 0.0.0.0/0 di EIGRP
Advertise ip loopback dan ip network ke EIGRP di R1 R2 dan R3
di R3 Hapus ip loopback1 -5
Bikin 6 IP Loopback di R1
interface Loopback1
ip address 10.10.10.1 255.255.255.255
!
interface Loopback2
ip address 10.10.10.2 255.255.255.255
!
interface Loopback3
ip address 10.10.10.3 255.255.255.255
!
interface Loopback4
ip address 10.10.10.4 255.255.255.255
!
interface Loopback5
ip address 10.10.10.5 255.255.255.255
!
interface Loopback6
ip address 10.10.10.6 255.255.255.255
!
kemudian bikin access-list di R3, karena kita akan memfilter di R3
R3(config)#access-list 1 permit 0.0.0.0 255.255.255.254
Artinya hanya ip loopback genap yang diijinkan
Distribute ke EIGRP di R3
R3(config)#router eigrp 1
R3(config-router)#distribute-list 1 in e0/0
kemudian verifikasi di R3
R3(config)#do sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 23.23.23.2, 00:03:10, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 3 subnets
D 10.10.10.2 [90/2323456] via 23.23.23.2, 00:03:10, Ethernet0/0
D 10.10.10.4 [90/2323456] via 23.23.23.2, 00:03:10, Ethernet0/0
D 10.10.10.6 [90/2323456] via 23.23.23.2, 00:03:10, Ethernet0/0
12.0.0.0/24 is subnetted, 1 subnets
D 12.12.12.0 [90/2195456] via 23.23.23.2, 00:03:10, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/0
L 23.23.23.3/32 is directly connected, Ethernet0/0
R3(config)#
Mantab terlihat pada tabel routing tersebut IP Loopback yang ditampilkan
hanya yang genap saja yaitu 10.10.10.2, 10.10.10.4, 10.10.10.6
selanjutnnya kita rubah kita filter, dan yang muncul hanya yang ganjil saja
rubah access listnya
R3(config)#no access-list 1 permit 0.0.0.0 255.255.255.254
R3(config)#access-list 1 permit 0.0.0.1 255.255.255.254
network 0.0.0.1 menunjukan bilangan ganjil dan 0.0.0.0 menunjukan bilangan
genap, maka yang akan muncul adalah yang ganjil.
verifikasi lagi di R3
R3(config)#do sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2323456] via 23.23.23.2, 00:03:16, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 3 subnets
D 10.10.10.1 [90/2323456] via 23.23.23.2, 00:03:16, Ethernet0/0
D 10.10.10.3 [90/2323456] via 23.23.23.2, 00:03:16, Ethernet0/0
D 10.10.10.5 [90/2323456] via 23.23.23.2, 00:03:16, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/0
L 23.23.23.3/32 is directly connected, Ethernet0/0
Sipp mantabbb surantapp, pada routing table di atas hanya ip loopback yang
ganjil yang di tampilkan.
sampai sini berhasil yah.
Salam Ngoprek