IBGP dan EBGP Peering

hapus dulu konfigurasi IBGP dan static route di R1 dan R2

R1(config)#no router bgp 100
R1(config)#no ip route 2.2.2.2 255.255.255.255 12.12.12.2

R2(config)#no router bgp 100
R2(config)#no ip route 1.1.1.1 255.255.255.255 12.12.12.1

setelah dipastikan konfigurasi sebelumnya di hapus kecuali ip addreess dan ip loopbacknya

kalau pada lab sebelumnya menggunakan static route kalau di lab ini kita menggunakan dinamic
route yaitu EIGRP, konfigurasikan EIGRP di R1 R2 dan R3

R1 dan R2 Directly Connected
R2 dan R3 Directly Connected
R1 dan R3 Bukan Directly Connected

Agar semuanya bisa terhubung Oleh karena itu advertise semua Network Interface ataupun IP Loopback baik itu di R1 R2 dan R3
ke EIGRP

kalau kita mau mengadvertise ip loopback jangan lupa advertise ip interface

tanpa ip interface ip loopback tidak akan berfungsi ketika di routing menggunakan EIGRP
IP Interface sudah masuk EIGRP, dan IP Loopback Masukan ke EIGRP

di R1
R1(config)#router eigrp 10
R1(config-router)#network 1.1.1.1 0.0.0.0
R1(config-router)#network 12.12.12.1 0.0.0.255
R1(config-router)#
*Jul 30 04:30:24.934: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 12.12.12.2 (Ethernet0/0) is up: new adjacency
R1(config-router)#

di R2
R2(config)#router eigrp 10
R2(config-router)#network 2.2.2.2 0.0.0.0
R2(config-router)#network 12.12.12.2 0.0.0.255
R2(config-router)#
*Jul 30 04:30:24.945: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 12.12.12.1 (Ethernet0/0) is up: new adjacency
R2(config-router)#network 23.23.23.1 0.0.0.255
R2(config-router)#
*Jul 30 04:31:45.211: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 23.23.23.2 (Serial2/0) is up: new adjacency
R2(config-router)#

di R3
R3(config)#router eigrp 10
R3(config-router)#network 3.3.3.3 0.0.0.0
R3(config-router)#network 23.23.23.2 0.0.0.255
R3(config-router)#
*Jul 30 04:31:45.216: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 23.23.23.1 (Serial2/0) is up: new adjacency


Setelah semua Router berhasil melakukan Adjecency selanjutnya konfigurasi IBGP di R1 dan R2
menggunakan IP Loopback
R1(config)#router bgp 100
R1(config-router)#neighbor 2.2.2.2 remote-as 100
R1(config-router)#neighbor 2.2.2.2 update-source lo0
R1(config-router)#
*Jul 30 04:36:41.596: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up

R2(config)#router bgp 100
R2(config-router)#neighbor 1.1.1.1 remote-as 100
R2(config-router)#neighbor 1.1.1.1 update     
*Jul 30 04:36:41.597: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up
R2(config-router)#neighbor 1.1.1.1 update-source lo0

cek di ip bgp summary untuk verifikasi

R1(config-router)#do sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4          100       4       4        1    0    0 00:00:24        0


R2(config-router)#do sh ip bgp summary
BGP router identifier 2.2.2.2, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4          100       4       4        1    0    0 00:00:33        0

Selanjutnya konfigurasi EBGP di R2 dan R3
sebelum konfigurasi EBGP ada suatu hal yang penting yaitu metode Routing BGP merupakan UNICAST
yang artinya berkomunikasi one to one, saya jabarkan sedikit dilab ini R1 (1.1.1.1) dan R2
(2.2.2.2) sudah berkomunikasi dan melakukan BGP adjecency atau lebih simplenya R1(1.1.1.1)
 nembak ke R2 (2.2.2.2), nah ketika ada R3, R2 melakukan peering dengan R3 menggunakan.

R1 ke R2, R2 ke R3

karena ip loopback R2 (2.2.2.2) sudah digunakan oleh R1 (1.1.1.1), nah agar terhubung R3 ke R1
,kita harus create ip loopback baru di R1 R2 dan R3 hal ini yang mengbungkan EBGP di R3
ke R1 dan R2

lebih simplenya gini yah
loopback R1>R2 IBGP
loopback R2>R1 IBGP
loopback R2>R3 EBGP

loopback baru R1 advertise ke BGP 100 di R1
loopback baru R2 advertise ke BGP 100 di R2
loopback baru R3 advertise ke BGP 200 di R2

IP Loopback yang baru ini berfungsi untuk menghbungkan R3 ke R1, ataupun R3 ke R2 sehingga BGP
dapat terbentuk.

kita tambah ip loopback yah di R1 R2

R1(config)#int lo1
R1(config-if)#ip add 11.11.11.11 255.255.255.255

R2(config)#int lo1
R2(config-if)#ip add 12.13.12.12 255.255.255.255

R3(config)#int lo1
R3(config-if)#ip add 33.33.33.33 255.255.255.255


Bisa menggunakan Interface bisa menggunakan loopback

IBGP Perring R1 ke R2 menggunakan IP Loopback
EBGP Peeringg R3 ke R2 menggunakan IP Interface /network 23.23.23.0 (network R3 ke R2)
EBGP Peering R3 ke R1 menggunakan IP Interface /network 12.12.12.0 (network R2 ke R1)

Namun di lab ini saya menggunakan IP Loopback

Sehingga IBGP tidak terganggu dengan adanya EBGP di R3
IBGP dan EBGP dapat terhbung dengan baik


Setelah di create IP Loopback baru selanjutnya advertise ke BGP

R1(config)#router bgp 100
R1(config-router)#network 11.11.11.11 mask 255.255.255.255

R2(config)#router bgp 100 
R2(config-router)#network 12.13.12.12 mask 255.255.255.255

R3(config)#router bgp 200
R3(config-router)#network 33.33.33.33 mask  255.255.255.255

selanjutnya test ping dari R3 ke R1 menggunakan Ip loopback yang baru

R3(config-router)#do ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 10/10/11 ms


R1(config-router)#do ping 33.33.33.33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/9/11 ms

setelah di ping berhasil selanjutnya selanjutnya konfigurasi EBGP di R2 dan R3

R2(config)#router bgp 100
R2(config-router)#neighbor 3.3.3.3 remote-as 200
R2(config-router)#neighbor 3.3.3.3 update-source lo0
R2(config-router)#neighbor 3.3.3.3 ebgp-multihop 2 
R2(config-router)#

R3(config)#router bgp 200
R3(config-router)#neighbor 2.2.2.2 remote-as 100
R3(config-router)#neighbor 2.2.2.2 update-source lo0
R3(config-router)#neighbor 2.2.2.2 ebgp-multihop 2 
R3(config-router)#


Tunggu sampai adjecency antar router

lihat ketka menghubngkan ibgp dan ebgp, gunakanlah perintah ebgp-multihop 2 artinya ebgp akan
melewati 2 hop atau 2 loncatan, pertama ke R2 kemudian ke R1 

selanjutnya kita lihat ip bgp nya yah di tiap tiap router

R1(config-router)#do sh ip bgp 
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  11.11.11.11/32   0.0.0.0                  0         32768 i
 *>i 12.13.12.12/32   2.2.2.2                  0    100      0 i
 *>i 33.33.33.33/32   3.3.3.3                  0    100      0 200 i


R2(config-router)#do sh ip bgp 
BGP table version is 6, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 11.11.11.11/32   1.1.1.1                  0    100      0 i
 *>  12.13.12.12/32   0.0.0.0                  0         32768 i
 *>  33.33.33.33/32   3.3.3.3       

R3(config-router)#do sh ip bgp
BGP table version is 5, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  11.11.11.11/32   2.2.2.2                                0 100 i
 *>  12.13.12.12/32   2.2.2.2                  0             0 100 i
 *>  33.33.33.33/32   0.0.0.0                  0         32768 i


Tanda *> merupakan tanda best path, artinya jalur tersebut valid dan jalur terbaik untuk
dilalui

selanjutnya kita lihat juga tabel bgp routing di r1 r2 danr3

R1(config-router)#do sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      12.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B        12.13.12.12/32 [200/0] via 2.2.2.2, 00:40:09
      33.0.0.0/32 is subnetted, 1 subnets
B        33.33.33.33 [200/0] via 3.3.3.3, 00:39:11
R1(config-router)#



R2(config-router)#do sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/32 is subnetted, 1 subnets
B        11.11.11.11 [200/0] via 1.1.1.1, 00:40:57
      33.0.0.0/32 is subnetted, 1 subnets
B        33.33.33.33 [20/0] via 3.3.3.3, 00:39:26
R2(config-router)#


R3(config-router)#do sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/32 is subnetted, 1 subnets
B        11.11.11.11 [20/0] via 2.2.2.2, 00:41:12
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B        12.13.12.12/32 [20/0] via 2.2.2.2, 00:40:18
R3(config-router)#


Sampai sini selesei yah

Leave a Reply