Lab 1. MPLS Backbone
Pada dasarnya MPLS (Multi Protocol Label Switch ) terdiri dari 3 jenis router:
1. Router P (Provider)
- Terdapat dalam MPLS domain, P router terhubung dengan router router
lain yang dimiliki service provide
- Pada jaringan MPLS yang tidak terlalu besar terkadang tidak terdapat
P router didalamnya untuk menghemat biaya.
2. Router PE (Provide Edge)
- Merupakan router yang terhubunglangsung dengan rourouter customer
danjuga sekaligus dengan router service provider.
- Menjembatani antar network berbasis IP dan network berbasis MPLS
- Memberikan pelabelan pada packet IP yang masuk ke dalam MPLS domain.
- PE router sifatnya harus ada pada setiap jaringan MPLS
3. Router CE (Custumer)
- merupkan router yang terdapat disisi customer.
- Pada Router CE ini, tidak terdapat konfigurasi MPLS apapn
- Konfigurasi Routing biasa, bisa static routing maupni IBGP
Konfigurasi IP Address dan Aktifkan MPLS pada Interface di Router1 PE
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.1 255.255.255.0
mpls ip
!
Konfigurasi OSPF dan BGP di R1
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 13
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 13
neighbor 3.3.3.3 update-source Loopback0
!
Konfigurasi IP Address dan aktifkan MPLS pada Interface di R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.2 255.255.255.0
mpls ip
!
interface Ethernet0/1
ip address 23.23.23.2 255.255.255.0
mpls ip
!
Konfigurasi OSPF di R2
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 23.23.23.2 0.0.0.0 area 0
!
Konfigurasi IP Address dan aktifkan MPLS pada interface di R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 23.23.23.3 255.255.255.0
mpls ip
!
Konfigurasi OSPF dan BGP di R3
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 23.23.23.3 0.0.0.0 area 0
!
router bgp 13
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 13
neighbor 1.1.1.1 update-source Loopback0
!
test ping ke IP Loopback R1 R2 dan R3
R1(tcl)#foreach address {
+>(tcl)#1.1.1.1
+>(tcl)#2.2.2.2
+>(tcl)#3.3.3.3 } {ping $address}
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/5 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/6 ms
R1(tcl)#exit
Verifikasi BGP Neighbor di R1 dan R3, R2 tidak di konfigurasi BGP karena status
nya sebagai Router Provider (P)
R1(config)#do sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 13
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
3.3.3.3 4 13 6 6 1 0 0 00:02:18 0
R3(config)#do sh ip bgp summary
BGP router identifier 3.3.3.3, local AS number 13
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 13 6 6 1 0 0 00:02:05 0
Verifikasi MPLS di R2
R2(config)#do sh mpls interface
Interface IP Tunnel BGP Static Operational
Ethernet0/0 Yes (ldp) No No No Yes
Ethernet0/1 Yes (ldp) No No No Yes
Verifikasi MPLS Forwarding di R1
R1#sh mpls forwarding
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label 2.2.2.2/32 0 Et0/0 12.12.12.2
17 17 3.3.3.3/32 0 Et0/0 12.12.12.2
18 Pop Label 23.23.23.0/24 0 Et0/0 12.12.12.2
Terlihat pada tabel mpls forwarding R1, mendapatkan local label 16 kemudian
di forward ke R2 dan di POP Label sehingga berubah menjadi Label 17, dari R2
Label 17 di forward ke R3 dengan label yang sama label 17, dari R3 menjadi
label 18 kemudian di POP label ke prefix ip interface 23.23.23.0/24.
seperti itulah proses komunikasi antar router pada MPLS Backbone.
Selesei
Salam Ngoprek